The Sinister Design Forums

Please login or register.

Login with username, password and session length
Advanced search  

News:

Welcome to the new Sinister Design forums!

Author Topic: Invalid Application Descriptor  (Read 2056 times)

mathandr

  • Ghost
  • Offline Offline
  • Posts: 1
    • View Profile
Invalid Application Descriptor
« on: April 17, 2015, 02:01:54 PM »

Hi,

I just purchased this game last night on Steam and when I try to run it I get an error message:

"This application has an invalid application descriptor. Try re-installing or contacting publisher for assistance."

I uninstalled it, reinstalled it, verified the files, ran as administrator, and ran it in compatibility mode but continue to get the same error. No log is created.

I am running windows 7.

Also, on a side note, there are waaay too many security questions on this forum for the average person to want to use it, especially after registering.
Logged

CraigStern

  • The Creator
  • Administrator
  • Tactician
  • *****
  • Offline Offline
  • Posts: 2820
    • View Profile
    • Sinister Design
Re: Invalid Application Descriptor
« Reply #1 on: April 17, 2015, 02:36:25 PM »

Hey there! That error usually indicates a problem with TTwm-app.xml. You can find that file in your game's install folder; do me a favor and attach it to your post so I can inspect it and see what might be going wrong.
Logged

nessuno

  • Ghost
  • Offline Offline
  • Posts: 1
    • View Profile
Re: Invalid Application Descriptor
« Reply #2 on: April 17, 2015, 03:38:23 PM »

I have the same problem. Here is my files.
Thanks for help
Logged

Chatterly

  • Ghost
  • Offline Offline
  • Posts: 2
    • View Profile
Re: Invalid Application Descriptor
« Reply #3 on: April 17, 2015, 09:10:31 PM »

I also have this issue. I am not finding the xml file you list. Happy to supply or test anything you like.

Also, Retyping the verification questions is already old. Just FYI
-C
Logged

CraigStern

  • The Creator
  • Administrator
  • Tactician
  • *****
  • Offline Offline
  • Posts: 2820
    • View Profile
    • Sinister Design
Re: Invalid Application Descriptor
« Reply #4 on: April 17, 2015, 09:24:03 PM »

Hm; the application.xml descriptor looks identical to mine, and my install runs fine. I guess we can rule that out, then.

I saw someone post a thing saying that installing the latest version of Adobe AIR fixed this for them. Why not give that a try and see if that does it?
Logged

Chatterly

  • Ghost
  • Offline Offline
  • Posts: 2
    • View Profile
Re: Invalid Application Descriptor
« Reply #5 on: April 17, 2015, 09:58:03 PM »

That fixed it! Thanks.

-C
Logged

CraigStern

  • The Creator
  • Administrator
  • Tactician
  • *****
  • Offline Offline
  • Posts: 2820
    • View Profile
    • Sinister Design
Re: Invalid Application Descriptor
« Reply #6 on: April 21, 2015, 08:17:43 AM »

I believe this bug should be fixed in the latest version of the game (1.01), but I'm keeping an eye out in case anyone new has this problem.
Logged

CraigStern

  • The Creator
  • Administrator
  • Tactician
  • *****
  • Offline Offline
  • Posts: 2820
    • View Profile
    • Sinister Design
Re: Invalid Application Descriptor
« Reply #7 on: April 27, 2015, 07:44:33 AM »

I haven't seen any new reports of this bug appearing in the past week--I'm going to assume that it has, in fact, been fixed. Marking as resolved!
Logged