The Sinister Design Forums

Please login or register.

Login with username, password and session length
Advanced search  

News:

Welcome to the new Sinister Design forums!

Author Topic: Can't equip items v1.049  (Read 675 times)

Elkki

  • Ghost
  • Offline Offline
  • Posts: 1
    • View Profile
Can't equip items v1.049
« on: October 03, 2015, 02:41:51 AM »

My initial sword ran out of uses and the option to equip a new sword or any other item doesn't show up. Had to play few missions without Emma or Sabrina attacking, but something tells me I won't be able to rely on that this time.
Logged

CraigStern

  • The Creator
  • Administrator
  • Tactician
  • *****
  • Offline Offline
  • Posts: 2787
    • View Profile
    • Sinister Design
Re: Can't equip items v1.049
« Reply #1 on: October 04, 2015, 12:55:47 PM »

Thanks for the report! I'll look into this.
Logged

moskewcz

  • Mechanic
  • *
  • Offline Offline
  • Posts: 17
    • View Profile
Re: Can't equip items v1.049
« Reply #2 on: October 04, 2015, 05:14:31 PM »

did you, by chance, start with an earlier version of TT and then upgrade later? there seems to be an unresolved issue with save game non-portability across versions. otherwise, i dunno. your save game seems to have a mix of old and new syntax for item requirements.

i had/have a similar problem with my save games, so i wrote a script to maybe-correctly-update them. buyer beware, of course:

https://gist.github.com/moskewcz/7f676243b910afb80178

i filter your savegame though (attached) and it seems to be fixed ...

Logged

CraigStern

  • The Creator
  • Administrator
  • Tactician
  • *****
  • Offline Offline
  • Posts: 2787
    • View Profile
    • Sinister Design
Re: Can't equip items v1.049
« Reply #3 on: October 04, 2015, 08:14:05 PM »

Ah, okay--this was actually an easy one! I just had to update your items that you obtained before version 1.047. (The class requirements for items changed in version 1.047, in that they became delimited with a double-colon instead of a single colon.)

The fixed file is attached.
Logged