Welcome to the new Sinister Design forums!

Main Menu

[MAP EDITOR] - Cannot locate TT installation directory

Started by bugfartboy, April 22, 2015, 01:53:22 PM

Previous topic - Next topic


When you install Telepath Tactics through Steam, the Map Editor gives several different loading errors, including:
Quote from: Loading Error!Couldn't get the file! null/ObjClasses.xml
Quote from: Loading Error!Tiles subdirectory not at app:/Tiles
Quote from: Loading Error!Tiles subdirectory not at file:///C:/Program%Files%20(x86)/Telepath%20Tactics/Data/Tiles
Quote from: Loading Error!Data subdirectory not at file:///C:/Program%20Files%20(x86)/Telepath%20Tactics/Data!

To ensure that the map editor simply hadn't updated where to look for files, I uninstalled and reinstalled the editor.  I was met with the same barrage of messages.


If you're running the Steam version, you need to physically move the map editor's install folder to the same location as the Telepath Tactics install folder (most likely C: > Program Files (x86) > Steam > SteamApps > common). It should work then. ;)


I tried your solution CraigStern, and the Map Editor worked. But then when I try to launch Telepath Tactics it launches the Map Editor and not the game.


Wait. You moved the folder Telepath Tactics Map Editor into C: > Program Files (x86) > Steam > SteamApps > common, and hitting Play in Steam  made Steam run the map editor instead of Telepath Tactics?

Sigh. Okay. Looks like I'm going to have to spend yet more time coming up with a special workaround for Steam's ridiculous nonsense.


Oops... Forget about it, I've made a mistake. I didn't install the map editor's folder in the same location as the Telepath Tactics folder but I installed it in the Telepath Tactics folder...

I know, I am stupid. Sorry for the fright. :(