The Sinister Design Forums

Games => Telepath Tactics (2015) => Telepath Tactics Bugs => Topic started by: Elvin on August 05, 2015, 10:33:00 AM

Title: Latest patch has several issues
Post by: Elvin on August 05, 2015, 10:33:00 AM
So it seems there's been a path 1.039, which Steam game to me today, the 5th August, despite the developer's log saying it was released on the 16th July. Either way, I now seem to be running 1.039 and it has broken several things about the new game I started two days ago, just as I was coming back to this after hoping all the bugs that destroyed my last game were fixed.

First, the full-screen scaling was turned on by default, and despite me running in 2560x1440, i.e. 16:9 as mentioned in the Dev's Notes thread, when I loaded the battle I'm at the screen was horrifically broken, in that I could not see most of the deployment positions of my characters, and I could not pan the screen in any way. I tried pressing "done" to end deployment, but then I was unable to see the action box, so could not open the menu to quit the game (why doesn't esc open the menu anyway?). This forced a ctrl-alt-delete of the process.

Next thing I noticed, after turning off the screen scaling, was that most of my equipment was broken - specifically, everyone who had any equipped items. They appeared as blank squares, with the name of the item instead of the picture. The tooltips also read as e.g. "Iron Sword 0 equipped to weapon hand", rather than the usual strength boost, uses left ,etc. This prevented most of my characters from attacking. Attempting to unequip a sword sent the character to -100 health...

The third problem is a bunch of "load warning errors" popup, with text like "Attacking spearman not present in XML". There were about 5 such messages, which I believe corresponds to the number of enemies on the screen.

So it looks like, for me at least, the game is currently unplayable, which is sad because I really wanted to finsih it this time, and not run into the slow down and item swapping bugs. I don't suppose its in any way possible to just get back to 1.038? That seemed stable.

Title: Re: Latest patch has several issues
Post by: CraigStern on August 05, 2015, 02:32:55 PM
Hey! I'm pushing version 1.04 right now, which should hopefully have answers to at least some of your woes. Are you on Steam?
Title: Re: Latest patch has several issues
Post by: Zetor on August 05, 2015, 08:42:55 PM
Heya,

I just updated to 1.04 (steam), and having the same problems as in the OP: popups with errors about champion/spearman/pikeman attacks missing, icons having placeholders, unable to attack with Madeleine even though I have an axe equipped (so the placeholder axe isn't recognized as an actual axe), unable to leave 'reserve supplies' screen, etc. I'd add that items in the 'reserve supplies' screen seemed to have their normal icons, and when I equipped them on someone, they seemed to work OK - see screenshot. Consumables weren't affected either.
There was some really weird stuff happening when I [de]equip gear -- the characters' HP bars change, Gavrielle's Perception seems to change (what's Perception? I thought we only had Accuracy?). Stuff like that.

edit: Also, I tried using the convert saves button, but it didn't seem to do anything. Maybe this is kinda related to an earlier problem about AIR using savegames from its own cache instead of TT's?

(Sorry Elvin, didn't mean to hijack your thread, but I think this is a critical issue that needs as many reports as possible)
Title: Re: Latest patch has several issues
Post by: Elvin on August 06, 2015, 01:04:15 AM
I am on Steam, and have updated to 1.04. I pressed the "convert save files", and yet I am still seeing exactly the same list of problems:

I've attached the newly created XML save file, but I haven't tested if it actually is using this one or not by e.g. randomly editing it.

Title: Re: Latest patch has several issues
Post by: CraigStern on August 06, 2015, 05:20:42 AM
Okay--sorry you're having issues! I'll look this over and figure out the issue ASAP.

Edit: Okay, I just loaded up your save file. I'm able to open and close the Manage Inventory screen, but it looks like a few of the items aren't being parsed correctly, which is probably causing the issue. I'll get right on fixing this; I should hopefully have an update by tomorrow.

Yeah; it looks like it formatted the class requirements attribute for a handful of the items incorrectly. Lines like this...

Code: [Select]
<CommonInv>Iron Sword||Weapon Hand||c:Swordsman||Fencer||Hero||Champion||||||Sword||23||100||0||0||0||0||0||0||5||0||0||0||0||0||0||0||0||0||0||0||0||0||0||5||||Sword||Ordinary iron sword. Strength +5.</CommonInv>
...should look like this

Code: [Select]
<CommonInv>Iron Sword||Weapon Hand||c:Swordsman,Fencer,Hero,Champion||||||Sword||23||100||0||0||0||0||0||0||5||0||0||0||0||0||0||0||0||0||0||0||0||0||0||5||||Sword||Ordinary iron sword. Strength +5.</CommonInv>
and this

Code: [Select]
<Inv>Leather Armor,Torso,c:Swordsman,Fencer,Spearman,Pikeman,Cavalier,Mantis Knight,Hero,Champion,Bandit,Marauder,Crossbowman,Arbalist,Drake,Mentalist,Puppetmaster,Pyrokineticist,Pyrokurios,Cryokineticist,Cryokurios,Skiakineticist,Skiakurios,Photokineticist,Photokurios,,,,0,120,0,0,0,0,0,0,0,0,0,0,5,10,5,0,0,0,0,0,0,0,0,7,,Armor Leather,+5% physical res. (10% vs Slash).||
should be like this:

Code: [Select]
<Inv>Leather Armor,Torso,c:Swordsman/Fencer/Spearman/Pikeman/Cavalier/Mantis Knight/Hero/Champion/Bandit/Marauder/Crossbowman/Arbalist/Drake/Mentalist/Puppetmaster/Pyrokineticist/Pyrokurios/Cryokineticist/Cryokurios/Skiakineticist/Skiakurios/Photokineticist/Photokurios,,,,0,120,0,0,0,0,0,0,0,0,0,0,5,10,5,0,0,0,0,0,0,0,0,7,,Armor Leather,+5% physical res. (10% vs Slash).||
Title: Re: Latest patch has several issues
Post by: Elvin on August 06, 2015, 01:13:22 PM
Thanks for investigating. The XML save could well be wrong, but is there a second error in "Attacks.xml"? When I press to start the battle, I see errors that read "Attack Spearman was not in Attacks.xml on scene start". Looking at the relevant Attacks.xml for the campaign, it looks like the game is attempting to load an attack that is named after the unit, rather than the name of the weapon, at least from my initial impression of how you've set out Attacks.xml.

Title: Re: Latest patch has several issues
Post by: CraigStern on August 07, 2015, 07:52:33 AM
Unlikely--the way Attacks.xml is parsed hasn't changed. The most likely explanation is that it was caused by the item parsing issue, with the game mistakenly reading one of the required classes to use the item as the attack granted by that item.