Welcome to the new Sinister Design forums!

Main Menu

Characters weapons swapped

Started by Chris, April 26, 2015, 11:26:46 AM

Previous topic - Next topic


Thanks for the detailed reports and saved game files, guys! I'm going to take another crack at fixing this tonight. :)


Another thing you could try to trigger it is start a map, replace the default members on the field with some reserve guys then save. Start the battle then surrender and try again. I believe this is when I saw both the portrait swapping and mixing/losing of items. Even closing the game and reloading the save file did not work, it somehow saved with the items missing.

Here you can see a screenshot of my Photokineticist wielding a steel sword like a boss -  :o

If you want my save file let me know.


Craig, why did you forbid to drop the incompatible inventory? We could at least drop and redistribute it earlier, but now it is not even possible to work around the bug.
Someone should really stop messing up with the ids of characters and items.


First off Telegraph Tatics, awesome achievement Mr Stern!. I'm loving it, Thank you sir.

So my version patched to 1.03 yesterday. I continued playing an old 1.029 save where I had been having these equipment swapping, duping and disappearing issues which lead me to suspect the character/eqipment database was being corrupted some how. As I continued playing in ver 1.03 the issues were still appearing to the point where it became impossible to continue at the entance to the mines. Your patch notes suggested this problem had been solved so decided to ditch the old save and start fresh. I've started a new campaign and I've hit my first issue at Gunthers first battle, after succeeding to rescue the flying creature from prision without losing any of my party. Importantly however regarding a potential database corruption, before successfully completing the mission I had quit and restarted the client because I got a party member killed because of a silly mistake and wanted to restart the level. so I quit by ALT+TABing and right clicking 'close window' on the application icon in the taskbar (ie. not following the correct process of quitting by clicking options/quit game)

I had no problems on the 2nd attempt at the rescue mission regarding swapping characters, equipment etc but as I had all 8 characters on the field I didn't have to swap any characters out of the reserve list (because there were no reserve charaters at that time.) on Gunthers following level I had the new flying character, and so now one in reserve, but when I tried to swap it into the party the game refused to let me put it in any deployment slot with an accompaning 'duh duh' sound. I could however move and arrange the members of the party already deployed in their field positions

I'm not sure if you can reproduce this but if you can, to my thinking, maybe shutting down the app in mid game incorrectly is somehow corrupting your database. Quitting out correctly and restarting the client didn't fix the problem of swapping characters. The only way I found to fix it was a computer restart which I find peculiar unless you are somehow storing the database in a memory location and it is maintained even after the game is closed and restarted.

I really love the potential of this game but this equipment bug becomes a proper gamebreaker as the number of characters that joins your party increases and charater inventory management becomes increasingly important. Hopefully you did solve it in 1.3 and this is an unrelated other bug but I suspect it is related and wanted to get this report in. I'll keep playing and let you know if my equipment swapping, duping and disappearing starts happening in later in this version 1.03 run through. Right now I suspect it will start happening because this was how the problems started for me in version 1.029. If you don't hear from me in the next day or two about this bug escalating into the equipment swapping, duping and disappearing then maybe move this bug report elsewhere. I hope you manage to solve it :)

As a side note - at times there is no easy way to quit the game, ie from the deployment screen (apart from first deploying troops clicking through dialogue hitting ESC a couple of times clicking options, then clicking quit. The tendency for a player to quit by ALT+F4 or by ALT+TABing and killing the client is likely quite high. I hope some of this might be helpful for you Craig. Good luck bug fixing and once again thank you for this potentially excellent game :)


ok the next weird thing has occured with character selection, this time a picture is attached with the log. This is gunthers level and I have just start playing again after restarting the Computer to fix the bug that was preventing me moving Meridian into the party. you can clearly see meridian now deployed on the field but notice that she doesn't appear in the line you drag equipment to. Madilane is listed both in the reserve list and the deployed list, Meridian is not available at all to drop equipment onto.


Apologies if I appear to be hijacking this thread with a list of unrelated bugs but i started here and it's a sequence of events might potentially leading to the bug in the title so...

having deployed despite the bug I screwed up and restarted the the level again this time using the proper quit function. The 2nd attempt I beat gunther and then in the dialogue cutscene that normaly should appear there was just a background but no characters or text. A click or two moved past the cutscene and onto the next level....see attached pic and logs

I think I'm gonna restart the campaign entirely again this time with no restarts or quiting any of the levels and see if it keeps happening....