Welcome to the new Sinister Design forums!

Main Menu

1.047 issue with item requirements (possibly only for legacy saves)

Started by Zetor, September 20, 2015, 08:25:29 AM

Previous topic - Next topic



I ran into a weird issue with the changes to the handling of item requirements introduced in 1.047. Basically, nobody can equip anything except for items with zero restrictions (like the chopper or torches)! Items that are already equipped work fine, but after Emma's sword broke, I found I could not equip anything. I'm not sure if completely new items work OK, I suspect they do.

The core of the problem seems to be confusing class requirements for race requirements:
887 | running isItemEquipped(); whichItem 1
888 |      allReqs[0] (race) = c:Swordsman:FenceHero:Champion
889 |      allReqs[1] (class) =
890 |      allReqs[2] (level) =
891 | checking against raceRequirements[0], c:Swordsman:FenceHero:Champion
892 | wrong race to use this item!

It *may* be a problem specific to games getting corrupted during the short period between 1.04 and 1.041 (if you remember the discussion on rpgcodex); I had to fix and keep using that save, my LP readers would've eaten me alive if I started anew :p If there's anything I can do to fix things up for this patch, let me know -- thanks!


oops, yep, i can confirm i have the same problem. when i said the item reqs bug seemed fixed in 1.047 for my save (in my 'main' bug thread), that was only based on looking at the requirements of a few items, not trying to equip them. i tried giving an axe to axe-lady, and i couldn't equip it, despite the listed requirements seeming correct.

i started a new game, and at least in the tutorial i could equip-unequip-equip the practice sword. as a bonus, i can verify that the cut-scenes do seem to render properly now. i'll update my most recent reply in my main bug thread.

for now i'll hope that the logs/saves in this thread are sufficient for this bug, but i'll make some of my own if requested and/or if my bug persists after any attempted fix/updates.



Yeah--to make old saves work, you'll need to change the single-colon delimiting of individual classes and races to double-colons. So this

Iron Bow,Weapon Hand,c:Bowman:Bowmaster

becomes this:

Iron Bow,Weapon Hand,c:Bowman::Bowmaster


Okay, thanks! Seems to work now...

For reference and/or others who may be interested, I used these (very ugly and/or brittle) regexes:

class reqs

replace with

race reqs

replace with

I assume stuff in the common inventory is delimited in a different way and should be left as it is.


Yup! And level requirements should start with l: (note that the only item in the game with a level requirement is Fangiss Ka).



I have this issue as well. Will you be providing a patch to fix old save games? If not, what application can I use to edit and save the save game without screwing it up?