Welcome to the new Sinister Design forums!

Main Menu

The early access bug reporting thread

Started by CraigStern, February 18, 2013, 10:39:47 PM

Previous topic - Next topic


Using SetStat to add 1000 Exp to a unit causes only the first 200 to register and cause a level-up, leaving the unit with 800/100 Exp remaining.  I looked for a log to attach, but wasn't able to find one that matched this particular run.

Using SetStat to change a character's name only changes the first name, leaving the last name the way it was before.  This was something I noticed on the same run I mentioned just a few lines up, so I don't have a log file to give you.


The game doesn't like it when you right click on a character that doesn't have a portait assigned to it.


Hey, I was playing around with the campaign (after forgetting this exists for a long while), and the game froze on this screen, and hung just like in the screenshot(I eventually closed it out, it never resolved).  Just a hunch - the guy in the water was supposed to drown to death this turn, I feel like that may have something to do with it.

Not sure if you know about it, or if it's something on my end.  Either way, figure I'd let you know.


Thanks for the tip! Do you have a game log you can post to help me figure out the cause of the freeze? (It'll be saved in Documents > My Games > Telepath Tactics > Logs, with the time the crash occurred in the filename.)


If Emma dies during the training scene with Silithis Predat the scene will reload, but the scripts that equip her with a training weapon do not run.  Exiting the game and reloading fixes this.


Quote from: bugfartboy on October 25, 2014, 12:38:40 AM
If Emma dies during the training scene with Silithis Predat

That should actually not be possible. Were you messing with the scripts, by any chance?


This looks like it, though the date on the log doesn't make any sense.  That said, based on what I can decipher from the contents, it looks like it's at the very least describing the right battle, so here you go:



Quote from: carlosfan666 on October 25, 2014, 01:54:51 PM
she dies if you attack her sister.
Yes. I forgot to mention, I attacked Sabrina when Emma was almost dead.  Emma died and the aformentioned bug occured.


Ohhhhhh. That makes sense. I'll see about fixing that.

Quote from: Purplemandown on October 25, 2014, 12:27:40 PM
This looks like it, though the date on the log doesn't make any sense.  That said, based on what I can decipher from the contents, it looks like it's at the very least describing the right battle, so here you go:

Thanks! I'll check into it when I get a moment.


For whatever reason, I have a full roster of teammates, yet I'm stuck on a map with no enemies to fight.


Ah, damn--just end the turn, it'll let you proceed.

I'll have a fixed build up tonight!


During the mission with the captured dark spriggat:
*One of my swordsmen was struck by a pyro blast and started burning.
*The following attack on the swordsman from an axman cause the swordsman sprite to disappear. All that was left of the character was her shadow.
*When I had the invisible character attack, the game froze.


Thanks! That's on my List of Things to Fix; I'll get to that ASAP.


Hello. I've been playing the most recent version, 0.455.531, quite a bit and have a few comments. The most pressing concern for me right now is that I can't play any more of the game as soon as one of my characters advances to level 20: I continually get the "Promotion!" dialogue box, but none of the character-specific information populates. I keep seeing the box with "null" and "0" instead of the character's name and class, respectively, and if I click to make it go away enough times, the game eventually freezes. It also looks like there are fireworks going off in the top-left corner of the screen, for some reason.

Let's see. This isn't so much of a bug as just a problem if you're trying to buff Scarlet's stats: it doesn't look like you can buy new lances for her until you reach Coria, which basically means that I couldn't use her in any battles for a good chunk of the middle of the game. Not a huge deal for me, as I had other characters that I was more interested in playing, but it could be frustrating on later runthroughs.

Also not a bug, but a comment about leveling Emma and Sabrina: at this point in my game, Emma's counter is 7 - and of course, it's basically impossible for her to counterattack seven times unless she gets a ranged attack later in the game - while Sabrina's counter (at just a slightly lower level) is still 1. It'd be nice to have Sabrina fight back more than one time when attacked during an enemy's turn, considering I think she is level 12 now and Emma's counter was 2 when she advanced to level 3. Is the way that characters level in TT entirely random (new attacks aside), or is there something that I'm missing?

And on using the rapier: when I have tried using the thrust attack to do some initial damage to a unit who counterattacks, I've found that my character will also counterattack, ending the turn. The end result is probably not so different from my original goal, except that at this point, that character with the rapier is also unable to counterattack on the enemy's turn if their own counter is too low. (Perhaps this is where a counter of 7 might make some sense, as I think about it...)

Another item question: should swordsmen be able to use the kite shield? I tried giving it to Emma and she was unable to equip it.

Ah yes. And I wasn't able to complete the first mission in the Coria Dogs' hideout unless I killed the bartender, which of course got me some demerits and made me feel a little guilty. :) I tried pulling the lever in the lower-right corner and putting different players (including Emma) on the square leading down to the basement, but nothing short of murdering the civilian did the trick.

On earlier versions, I was able to begin playing the black spriggat character (I forget her name now) following her rescue mission, but on this version, I haven't been able to and I actually didn't have the option of chatting with her at the camp afterwards, either. Similarly, the cutscene implies that the cryokineticist and engineer that you meet will be joining your party after they've been reunited with Lord Dakarai, but I haven't been able to play either of them since the mission where Emma's escaping Bloodbeard's stronghold.

I've also seen a handful of typos in the game, but unfortunately, I wasn't writing any of them down while I was playing. I do remember seeing "litle" in the pre-battle dialogue of the Coria Dogs boss fight, and I think I saw a typo in the item menu for the steel spear. Sorry I can't be more specific, but if I see any more, I'll be sure to keep tabs on them.

Just a few last points: for players who are as money-oriented as I am, seeing the amount of gold you've collected during a battle would be a fun thing to have in the end-battle statistics - and much more informative to my mind than the number of items collected, for instance. It would also be nice to be able to check how much money the party has from somewhere inside the menu; as it is, I don't really know how rich or poor I am until I actually find myself in a shop. And lastly, I find it very frustrating when enemies pick up sacks of aura that are dropped by other fallen enemies: even though it looks as if that enemy is gaining the gold in the sack, it isn't actually added to their inventory and it is thus effectively gone from the game. If it's too difficult to have an enemy already carrying 25 gold gain 50 more gold from a sack that he picks up, then perhaps there's a way to stop enemies from picking up drops? (Of course, it's possible that you designed the game this way deliberately, but I'd be surprised if you're that sadistic!) :P

I think that's everything I've noticed. It's been really fun playing this version, as there's a LOT of new content since the last time I played back in September. I look forward to seeing even more!

Peace out,

[Edit: Oops! Sorry, I somehow ended up modifying this post instead of replying; I've restored it now. My bad!]