Welcome to the new Sinister Design forums!

Main Menu

Telepath RPG: Servants of God buglist

Started by KZ, February 03, 2010, 11:23:18 AM

Previous topic - Next topic


In the Psy Duel card game, I found a bug where enemy minions will stay alive with zero or -1 health.

1. Use Cryo Blast, Dark Vortex, or one of your minions to kill an enemy minion.
2. Click on the Done button before the animation is finished; the minion will not die.  It will still be able to attack you and be a target for Fury.

However, it seems that the enemy will be removed if either you or your opponent plays another Cryo Blast or Dark Vortex.  It will also be removed if you kill a different enemy minion with your minions, but not if you just hurt the different minion.

So there's probably some code checking for minion death that gets skipped when you click the Done button.



I've got another one in Psy Duel.  I've only been able to make it happen twice, but there is a rare chance to cause a glitch by clicking on your card before they are done being dealt at the start of the game.  Both times I've caused it by clicking on a merchant or smuggler card that was flipped over before the rest of the cards were flipped.  What happens is somehow your psy points, silver coins, and gold coins aren't initialized properly and instead have Not a Number values (NaN).  The game treats these like you have an infinite supply, so you can play all your cards the first turn if you can make it happen.  I'm attaching a screenshot.  If you posted a new version yesterday, I have not yet downloaded it.


*Qudssi doesn't counter-attack
*In crypt 3 you spelled "cacophony" as "cacophany".
*Fernatus's Pyro Hail didn't cause friendly-fire damage to the Mech. Swordsman.
*During the "Distract the Guards" battle the enemies don't move unless they are in attack range.  When they kill Arman, they turns keeping going until the player wins.  (Arman should be killed by the Black Rose soon.)
*There are abolitionist in the Guard Patrols.
*When Malis learns shadowport and you click "show skill", she disappears, but doesn't reappear.
*Iblis's sandblast and sandstorm aren't visable.  The damage is done, but there isn't any animation.


Not positive if this is a bug, but after using the drugs and going through withdrawl symptoms, the restriction of movement has stayed after the other symptoms have worn off. Wish I had been paying better attention as to the timing, but I'm pretty sure I had increased movement through Arman before trying the drugs. If I take more, it restores my movement in battle. In character stats, movement speed remains at 6 regardless of actual speed in battle.

Another thing, also possibly not a bug, is that when I move the battle command interface to the bottom left or top left, the text that shows tooltips and reports the enemy's damage dealt disappears.


In crypt 3 at the door that says "Talk back to me", if I click on "Leave it alone", the text entry box goes away, but the dialog doesn't end.  I still have two choices, "Say something" (but without the text entry box) and "Leave it alone".  Clicking on either one does nothing.  At that point, I can't end the dialog and have to quit the game and reload.


Not precisely a bug, but the HUD window does seem to be poking out the wrong way when moved to the left. Since you were able to vertical-flip the window for up-down changes, might you be able to horizontal-flip it for left-right?


Not sure if this is a bug or the way it's supposed to be, but in Crypt 3 there is a lever that doesn't operate properly from range (using your mind).  The lever in the room to the right of the second riddle door works if you walk up to it and pull it, but if you pull it from a distance with psy, it will pull the lever, but then it pulls it right back again.  So you see the lever move, get the text for pulling it, then it moves back and you get the other text.  Here's a screenshot of the lever in question:



Hi. Since my net is quite slow, I played the game offline and wrote a list of the bugs I found.

I'm playing TSoG downloaded in 18/Aug/2011. I'm using Ubuntu 10.04 (a Linux distro).

I started playing the game from the tutorials. Here is what I found.

Tutorial: Combat
I can't see the buttons on the GUI in many pages:
- In moving, part 2.
- In attacking I wondered where are "those four square buttons..." :) And the enemy appears out of nowhere.
- In Done/Hold.
- In getting info. Furthermore, we can't see the other units.

Tutorial battle
Under manage orbs, we can see 13 orbs. Are we supposed to see them? The gold orb icon don't show up when you equip it.
In the manage team, we can remove all members from the roster and we can't add them back, except for the hero that has a blank rectangle.
I equiped 4 orbs (sorry but I don't remember which ones). After I removed the hero and added him back, in the battle screen appeared "<p align="left"></p>" and the stats were all NaN. No attack appeared (just a red x). I tried to attack a barrel and nothing happened. Afterwards, I could press the buttons and got messages like "already attacked" and "can't undo after attack" (should it be "after attacking"?), but the "done" button didn't work.

I played the tutorial battle and after destroying some barrels I went to the top escape square to win the battle. When I got back to the tutorial menu, I clicked "training" and the game resetted! Some NaN and html tags appeared at the top left corner.

On tutorial: advanced combat, the enemies aren't visible until they're attacked. The icons from the GUI aren't there either.

I'm not sure if it's a bug... The back button doesn't bring you to the previous page, it brings back to the tutorial menu.

In the intro, when the guards arrive, the screen blinks a lot (it might be because my computer is 7 years old and my graphics board is old).

I couldn't see the difference between the low and the best quality...

In the first battle, I put Griffin in the 2nd row, 3rd line and leave him there, while I left Duvalier in the 1st row, 1st line. The guard advanced and I stood still. The guard advanced again and attacked frontally Griffin, when he could attack him sideways, avoiding the Griffin's counter.

In the second battle I attacked with Griffin and moved quicly Duvalier and attack, while the animation of Griffin's attack was playing. The message "already attacked" appeared, although my attack with Duvalier worked. Latter, I attacked first with Duvalier and next with Griffin and the "already attacked" message appeared again.

For some reason, when I loaded the game from the prison, and when I replayed the 3rd battle, the bandit bowman didn't move.
Ert, the Dead Cow.
With 2 small Mandelbrot sets as the spots.


I had a strange feeling I was being followed...

Somehow part of a red spriggat was visible in the upper-left corner while walking around town.  It was animated too!  I had been playing a lot of Psy Duel.  When I restarted the game, it went away.


Sarlok: if you visit the game's install folder, do you see a file named CardGame.swf?


Yes.  I'm on the Mac, and the version I have was downloaded on August 17.  I've only ever had the Spriggat following me thing happen once.


Odd; I'll see if I can figure out the cause behind that.


Quote from: Ertxiem on August 25, 2011, 07:15:41 PM
Hi. Since my net is quite slow, I played the game offline and wrote a list of the bugs I found.

I'm playing TSoG downloaded in 18/Aug/2011. I'm using Ubuntu 10.04 (a Linux distro).

I started playing the game from the tutorials. Here is what I found.


Ert: have you tried using WINE by any chance?